nixcfg/systems/aarch64-darwin/m4/default.nix
Harald Hoyer ccc0eda517 feat: github ssh support
Signed-off-by: Harald Hoyer <harald@hoyer.xyz>
2025-01-15 13:19:49 +01:00

47 lines
656 B
Nix

{ lib, pkgs, ... }:
with lib.metacfg;
{
homebrew = {
enable = true;
brews = [
"libusb"
"mas"
];
masApps = { };
onActivation = {
cleanup = "zap";
autoUpdate = true;
upgrade = true;
};
};
metacfg = {
system.homebrew = enabled;
suites = {
common = enabled;
};
tools = {
direnv.enable = true;
alacritty.enable = true;
};
};
environment.systemPackages = with pkgs; [
# iterm2
# azure-cli
kubectl
kubectx
k9s
attic-client
ollama
imagemagick
gh
];
users.users.harald.shell = pkgs.fish;
system.stateVersion = 4;
}