- Added the `vault` package to the list of dev shell packages. - Adjusted formatting for parameter list to align with style conventions.
28 lines
446 B
Nix
28 lines
446 B
Nix
{ pkgs
|
|
, vault-hier
|
|
, rustVersion
|
|
,
|
|
}:
|
|
|
|
let
|
|
toolchain_with_src = (
|
|
rustVersion.override {
|
|
extensions = [
|
|
"rustfmt"
|
|
"clippy"
|
|
"rust-src"
|
|
];
|
|
}
|
|
);
|
|
in
|
|
pkgs.mkShell {
|
|
packages = with pkgs; [
|
|
vault-hier # Add the vault-hier package to the dev shell
|
|
toolchain_with_src # Add the custom Rust toolchain with source code to the dev shell
|
|
vault
|
|
];
|
|
nativeBuildInputs = [
|
|
vault-hier
|
|
];
|
|
}
|